Firebase & CocoaPods Issue

The issue was reported and solved by one of our good customer, very grateful for sharing it with us. I hope this article would be helpful for somebody who will experience the same. 

Original issue

Error building Player: iOS framework addition failed due to a CocoaPods installation failure. This will will likely result in an non-functional Xcode project.

After the failure, "pod repo update" was executed and succeeded. "pod install" was then attempted again, and still failed.

This may be due to a broken CocoaPods installation. See: https://guides.cocoapods.org/using/troubleshooting.html for potential solutions.

pod install output:

Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod "Firebase/Analytics":
  In Podfile:
    Firebase/Analytics (= 5.9.0)
None of your spec sources contain a spec satisfying the dependency: `Firebase/Analytics (= 5.9.0)`.

Solution

Firebase/Editor/MessagingDependencies.xml   

<iosPod name="Firebase/Messaging"  version = 5.9.0 

to

<iosPod name="Firebase/Messaging"  version = 5.1.0 

same  in Firebase/Editor/AppDependencies.xml   with name="Firebase/Core"

and same in Firebase/Editor/analyticsDependencies.xml