Setup for IOS


  • iOS version 4.3 or later
  • Xcode 4.5 or later

Plugin Setup

Note: Starting from version 5.1:

Since latest version Google AdMob SDK is provided as *.freamwork, you need to download and add it to your project manually. You can get latest AdMob SDK from the Downloads Pages.  After SDK is downloaded, unzip, drag and drop in your Xcode project in the root folder. Then need to enable check copy items if needed.


Add the GoogleMobileAds.framework.


Note: This step is automatic after 2.5 version. All frameworks and dependencies will be added automatically on the building phase. But in case you building Xcode project using windows this chapter may be useful.

1. The SDK library references the following iOS development frameworks which may not already be part of your project:

  • CoreTelephony
  • MessageUI
  • StoreKit
  • AdSupport
  • StoreKit.framework
  • EventKit.framework
  • EventKitUI.framework

To add these frameworks, double-click your project name. Open the Link Binary With Libraries drop-down under the Build Phases tab. Add the frameworks from the iOS SDK using the + button that becomes visible.

2. You now need to add -ObjC to the Other Linker Flags of your application target's build setting:

  1. In Xcode's project navigator, press the blue top-level project icon.
  2. Click on your target, then the Build Settings tab.
  3. Under Other Linker Flags, add -ObjC to both Debug and Release.

You should now be able to rebuild your project without any errors. And start using plugin functions.

If you are getting errors when trying to build Google Mobile Ads with Unity Ads on IOS platform follow this link.