Migrating to Unity5

WP8 Native plugin is ready to be used with the new Unity 5! At this chapter I will describe using differences comparing with the previous Unity version.

You need to set correct platform for the plugin native file.

Set Editor Platform for the following files, as showed on screenshot bellow:

  • Assets/Plugins/WP8Native.dll
  • Assets/Plugins/WP8PopUps.dll


Set the WP8Player platfrom for:

  • Assets/Plugins/WP8/WP8Native.dll
  • Assets/Plugins/WP8/WP8PopUps.dll

Set the WSAPlayer  platfrom for:

  • Assets/Plugins/Metro/WP8Native.dll
  • Assets/Plugins/Metro/WP8PopUps.dll